.

Saturday, September 27, 2008

My Royal Enfield won't start: Now what?

PLEASE NOTE: This 2008 article refers only to the classic iron-barrel Royal Enfield with which the author was familiar. For advice regarding newer (or older) Royal Enfield motorcycles I recommend you instead turn to the experts on the several Royal Enfield Yahoo groups that exist. Good luck.

You're all suited up for a ride on your Royal Enfield Bullet and it won't start. You have the fuel tap "on", the ignition on, the Kill Switch "on", the enricher (choke) "on" and you swing the kickstarter with no luck. Now what?

Relax. I mean that literally: get comfortable. Get your blood pressure down. Take off your helmet and jacket. Stretch. Have a cup of coffee. You want to approach the motorcycle with a fresh eye. Remember, the motorcycle is watching. You want it know you are the master.

Your first step should be to turn off the ignition and fuel tap choke and swing the kickstarter three or more times to clear the engine. Turn up the idle screw (clockwise as you face it) half a turn. That gives the motor a bit of extra throttle as it starts but not enough to flood it. You can turn the screw back down after the motor starts.

Try starting the motor without the choke. If that doesn't work, try with the choke. Still nothing? Have a sip of coffee and then, in a relaxed mood, take things step-by-step.

You only need three things to start a Royal Enfield: gas, compression and ignition. An empty gas tank is the easiest thing to rule out, so do that first. In Zen and the Art of Motorcycle Maintenance author Robert M. Pirsig described how a motorcycle trip came to a sad end. How? Because he refused to believe the bike was simply out of gas. If the tank has gas, check for a pinched gas line. All OK? Good.
Check for compression. Swing the kickstarter through its arc with the ignition off. If it comes to a point past which it is difficult to move the kickstart lever, compression is fine.
If not, compression is escaping. It can only get out of the cylinder three ways. It can go through the valves if they are too tight or a bit of carbon is holding one open. Swinging the kickstarter repeatedly should clear any carbon and the valves will only be too tight if you adjusted them last night and left them set wrong. They don't get tight on their own.
Compression can escape through the decompressor. Check that the cable that operates it isn't binding (perhaps when the handlebars turn) , opening the decompressor.
Finally, compression can escape past the piston rings. Remove the spark plug, put a dollop of oil in through the hole, replace the plug and see if compression returns. It should.
Now check for ignition. For this you need electricity. A Bullet with a dead battery will not start. Does the horn sound loudly? If so, the battery is good enough.
Set the Kill Switch to "run" and the ignition to "on" and swing the kickstarter. Is the needle on the amp meter swinging to the left and back to center as you do this? If so go on to the next step. If not, there is a bad connection somewhere. If that's the case you'll have to track it down and you might not be going riding today. Before you give up, reach into the back of the casquette and wiggle the wiring looms in there. This once brought the Bullet back to life for me.
If the amp meter is swinging normally, pull the spark plug and replace it with a new plug even if the old one looks OK. You only have one spark plug in a Bullet, so that one plug is 100 per cent of your ignition system inside the cylinder. You want it to be perfect. You do have a spare spark plug, right?
Remove the points cover and, with the ignition and Kill Switch "on" use a screwdriver to gently pry the points apart. If they spark you're good, but turn off the ignition and use a business card or other flat cardboard to clean the contact surfaces.
Your motorcycle will start on the very next try. If not, feel free to say anything you want about me in a comment here.

113 comments:

  1. Hi David,
    please look at this well known link.
    >http://www.cybersteering.com/cruise/feature/bullet/improve.html<
    Half way down the page you'll find a chapter named
    "Running without the Battery".
    It works.
    Regards,
    Johann

    ReplyDelete
  2. Johann, thank you for your comment. (And are you the Johann who tracked down the drawing of the new Bullet? Thank you for that too). The link you provide is a fun one with lots of tips from Bullet guru Nandan in India. No doubting anything he says. But my knowledge of electricity is limited to putting batteries in the flashlight. My Bullet doesn't have an "emergency" position for the key and Bullet electrical systems vary across the years, so I wouldn't try this myself.

    ReplyDelete
  3. my amp needle wont move also no spark could my kill switch be bad

    ReplyDelete
  4. Anonymous, if the amp needle doesn't move when you swing the kickstart lever with the ignition and kill switch on then, yes, you have a bad connection somewhere (or a completely dead battery). The kill switch itself is a suspect, but so is the rest of the electrical system. The problem may be as simple as a loose connector somewhere. One thing that worked for me: follow the ground wire of the battery to where it connects to the frame just behind the battery box. Remove it and make sure there is no paint or rust preventing good contact here; put it back on tight. Good luck.

    ReplyDelete
    Replies
    1. Sir, my new Royal Enfield classic 350cc bike were occurred starting trouble both kick start and self start were doesn't works. But now automatically working fine. Should I show it to workshop assistant or repair workshop.?
      Thank you

      Delete
    2. Was it stayed out in rain or did you give it a water wash ?

      Delete
  5. A lot of interesting information here. I am dealing with 2006 Electra. Was running with weak spark before I changed out the exhaust, and now there is no spark.
    I was sure if I was dealing with point ignition, but this has cleared everything up for me. I will attempt to rattle the wiring as well, and check the ground connection as well.

    This isn't my first rodeo...it's my second, but this feels like a good introduction in to the world of British motorcycles: Shake here, jump this to that, now the lights don't work, flail your arms and do a quarter turn in the air while jumping...

    ~Take It Easy~

    ReplyDelete
  6. Hey David,

    Been running my 03 Bullet 500 without issues. yesterday i turned the key on and nothing happened. No pilot lights, horn, nothing. It has a brand new battery only a few weeks old and It ran fine just a few days before. Any ideas?

    ReplyDelete
  7. The fact that you have a new battery suggests that maybe its connection wasn't put on tight enough, or it has loosened. Check the cleanliness/tightness of the connection to the frame behind the battery. It may have shifted just a bit and any bit of paint or rust here can cut the circuit.

    ReplyDelete
  8. My bullet runs fine when I can get it started - it starts - eventually - when cool and when warm runs beautifully but when hot (when i stall it) I can't start it at all and it cuts out at tickover. Any ideas

    ReplyDelete
  9. This is the best article I've seen about trouble shooting an Enfield. I'm learning all about engines and motorcycles through my newly acquired 2009 AVL and this article made that a lot less intimidating! Thanks for the help this morning... because of you I got a good ride in after trouble this morning.

    ReplyDelete
  10. Hi, great article but my Bullet won't start for different reasons. Mine sounds like there is severe grinding in the gears and the electric start sounds like it's cranking harder than usual. It cranks and cranks but never turns actually starts running. Any ideas?

    ReplyDelete
  11. Hi David Great article I have tried all those things and still cant get a spark. I have replaced the spark plug, the lead and the coil any ideas? cheers

    ReplyDelete
    Replies
    1. I'm going to have to fall back on my first comment here, which was that my knowledge of electrical systems is limited to putting batteries in a flashlight. I'm sorry. But I am not a mechanic and it would be wrong for me to offer half-baked suggestions to complex problems. Join the excellent Royal Enfield Yahoo Group and pose your question there.

      Delete
    2. Thanks Dave, will do. cheers Barry

      Delete
  12. Hey, i havea 1987 bullet 350 which i just rebuild last year ...the problem with it is thhat i guess iswinter now but it wont start properly. i canget it started after 15-20 kicks(sounds bad right) but if the bike is left off for 20 or so mins it becomes hard to startit agian.. any ideas?

    ReplyDelete
    Replies
    1. All the things mentioned in the article above apply. Have you tried them? I can only guess that your battery may be low on charge or not holding a charge. Good luck.

      Delete
  13. awesome article, thanks David! Besides a Bullet I also have a DT50 that always has a flat battery and I always kick start it back to life. I could never imagine the Bullet needs a fully charged battery to start, even when fitted with a kick starter! Thumbs up for a clear, short, concise, well written article

    Yiannis, Sydney

    ReplyDelete
  14. Hi David, I have a 2010 G5 Deluxe EFI and suddenly it has become almost impossible to start. Once I get it started it is fine for the rest og that day but next day it is back to square one. Kick starting it doesn't work and the electric start crankx over and over but won't catch.

    ReplyDelete
    Replies
    1. This article doesn't address bikes with electronic fuel injection. They ought to have fewer problems, not more; I am sorry you are having trouble. At a minimum, if I was you, I would replace the spark plug. Other than that, I have to modestly refer you to the nearest dealer. Good luck.

      Delete
  15. Great advice about relaxing, David. Such a simple thing but it so often helps when you're overlooking the obvious.

    Sit back. Look at the trees for a minute. Smoke a cigarette. Then look again.

    ReplyDelete
  16. For me the spark plug did the trick. Cheers David

    ReplyDelete
  17. Hi. . I have a bullet which is 1989 model.

    What happens if the ignition switch "ON" for such a long time?

    Now the battery is down :-(

    ReplyDelete
    Replies
    1. hi, i also faced this problem the main reason is a broken or short circuited alternator which is just beneath your seat on the rear mudguard

      Delete
  18. Thanks to your post, bull got running in 1 hour of break down :)

    ReplyDelete
  19. Seriously great post David... I ride a 84 350 bullet and unfortunately its giving me a huge starting problem... I have to kick it for atleast a good 20 times for it to start excluding the compression kicks... I have replaced the spark and the pilot light do turn on... Im confused if it is the battery or a loose connection... But for me to go for a ride i have to leave atleast 15 mins before so as to start the bike any suggestion...

    One thing i had changed my head light bulb but it is not strong enough... Could it be the battery... Also i do not have a horn to check if the battery is charged or not... Plz help... Thanks in advance

    ReplyDelete
    Replies
    1. The fact that your bike DOES start eventually suggests to me that the problem starting is something simple. Once the obvious things are attended to (new spark plug, clean points, a lively battery, fresh gas) continued problems starting might require the attention of a real mechanic with some simple diagnostic tools. As an alternative, pose your question in as much detail as possible to the experts on the Yahoo Royal Enfield Group.

      Delete
    2. whenever going to park Old point bullets for more than hour then before take off ignition key make sure ammeter point needle settled center properly otherwise battery would drain and next start would be like a war.

      Delete
    3. Many thanks for this tip.
      It has "cured" a problem that I didn't have :)
      Substantial draining of the battery. Battery OK even after removing anti-theft alarm and sundry other non broken bits, I can reassemble them all now!

      Delete
  20. I have Royal Enfield 350HP ,Year 2005,It does not get start after being replaced battery with full charged even no deflection in AMP meter,but could be the problem,it was Runing fine a month ago,all I did try to jump from my car battery one time.Please help me out.925-759-3266

    ReplyDelete
  21. HI DAVID, I HAVE A 1985 BULLET, EVEN AFTER CHANGING THE POINT AND NEW PLUG IT JERKS WITHIN RIDING, PLEASE GIVE SUGGESTION

    ReplyDelete
  22. I own the last 2008 std bullet with right side gear shift. Today My bullet died. It just wont start. I tried starting and ammeter wasn't responding. Hence found that due to the rains, water had entered in the cb point. Got that cleaned. Voila!! The ammeter started, but engine refuses to crank. Tried removing the spark plug, and there's no spark at all. Removed the spark plug adapter, removed the spark plug out and tried to short the wire against the engine and there's minor spark firing out of the HT cable, tried putting the spark plug back in and at the same time holding the HT cable against the engine(without the adapter) engine wont fire and there's no spark on the engine and neither the spark plug. Now I am confused. How on earth can i check if the Lucas Coil is working, or is bad??? The battery if fine, all indicator lights work fine including horn. This was a brand new spark plug, hardly rode for 300 km. Do let me know. Thanks!!!

    ReplyDelete
    Replies
    1. Ryan, I can't effectively troubleshoot your problem. A much better place to pose your question is on the Royal Enfield Yahoo Group. Join there and you will find real experts who can walk you through solving this. Good luck.

      Delete
  23. Hi David, thanks for replying. The issue was resolved after wasting 4 hours trying to figure out the problem when i finally decided to push my bike 5 kilometers away to the nearest local mechanic, who removed the cb points and cleaned them with sand paper and refitted the points back in, gave a nice kick and engine fired up without any issues. It's like a lemon. Lol!!!
    Thanks for the link, i have sent in a request for joining the group for any further help. Cheers!!

    ReplyDelete
  24. Hey I have Royal Enfield 1989 super deluxe model ,and in very bad condition , i have nor run this enfield for last 5 years and may be more .many parts are under attck of rust.I want to make it roar on the road again.is it possible? and where in North India?How much expenditure ?Please Help.
    Regards,
    Anish Thakur
    Himachal
    Ph:9459321520

    ReplyDelete
  25. These bikes are relatively simple compared to Japanese bikes , the best way to keep them on the road is to give them some regular basic maintainance and stay calm when things go wrong, just take a few moments to think things out, fuel , spark , kill switch , have you disturbed anything recently, also it helps to keep a notebook of whats been done and at what mileage so you have a record over time , don't expect spark plugs and points to last for ever , they are cheap and easy to fit .
    Neil in UK

    ReplyDelete
  26. Wen the key is ON .. Lights nd Horn are working .. But the ampere is nt wrking .. I changed the amp meter for 40 km it was smoothly wroking .. Den again same problem..ampere not wrking ..workshop guy said ampere meter gone :(

    ReplyDelete
  27. I am using elctra 350 2010 model. Having trouble with changing gear
    ..for eg... if i am on 2nd gear and wants to come on neutral its very diffciult ..its jammed. Especially in traffic its too hectic ...time again engine gets off and again i have to start ...please help me on this

    ReplyDelete
  28. Hi while starting my bull today there was a noise like that of a electrical short circuit and it was dead post that. I tried wriggling the wires and the neutral indicator lit but still the bike wont start. I checked the fuse and changed with the spare ones but to no effect. If someone could guide plz

    ReplyDelete
    Replies
    1. Unfortunately, posting in the comments here is not an effective way to get a full response to your question. My advice is that you join the Royal Enfield Yahoo Group and pose your question there. There are real experts on the forum who can help you.

      Delete
  29. Hi David,.
    My Spark plug and battery are fine ,. i doubt the compression,. can you please let know how to test and sort it out,.

    ReplyDelete
    Replies
    1. I'm sorry, but posting in the comments here is not an effective way to get a full response to complex questions. My advice is that you join the Royal Enfield Yahoo Group and pose your question there. There are real experts on the forum who can help you.

      Delete
  30. My royal enfiels classic wont start ...it starts when I turn on my choke ..but as soon as I turn it off it dies if I keep the throttle idle...and when I try the self starter it gives a sound as if it is missing a thump at times ...how to handle it

    ReplyDelete
    Replies
    1. Unfortunately, posting in the comments here is not an effective way to get a full response to your question. My advice is that you join the Royal Enfield Yahoo Group and pose your question there. There are real experts on the forum who can help you.

      Delete
  31. Hello can some one help me
    I have bought a 2009 500 cc royal enfield
    it is missing the sprag clutch assembly but that was fine with me as i was till now able to kick start it but yesterday i tried to change the exhaust from the new exgaust which was fitted in the bike to an old style bottle neck exhaust for better sound and thump.
    i srarted the bike alright but than switched it off and after that i have trued everything but bike would not start....i even tried push start but no luck
    any advice please

    ReplyDelete
    Replies
    1. Unfortunately, posting in the comments here is not an effective way to get a full response to your question. My advice is that you join the Royal Enfield Yahoo Group and pose your question there. There are real experts on the forum who can help you.

      Delete
  32. Hi David I just bought a royal Enfield Electra 350 was running OK but after 4days I tried to start my ride it won't start . battery is good . amps also moving . but when I check the plug there is little petrol smelling in that area. Is it the problem or some thing else please help.

    ReplyDelete
    Replies
    1. Unfortunately, posting in the comments here is not an effective way to get a full response to your question. My advice is that you join the Royal Enfield Yahoo Group and pose your question there. There are real experts on the forum who can help you.

      Delete
  33. There is no current on amp meter ??
    No movement of needle
    Help me out plz

    ReplyDelete
    Replies
    1. I'm going to have to fall back on my first comment here, which was that my knowledge of electrical systems is limited to putting batteries in a flashlight. I'm sorry. But I am not a mechanic and it would be wrong for me to offer half-baked suggestions to complex problems. Join the excellent Royal Enfield Yahoo Group and pose your question there.

      Delete
  34. Can a bullet 2004 jump start if its battery is dead

    ReplyDelete
    Replies
    1. I have started my Bullet when the battery was down simply by attaching the jumper cables to the battery; it wasn't even necessary for the vehicle doing the jumping to be running.

      Delete
  35. Hi David. I have 82 bull. Recently got it's engine redone. It's not starting with ease. Amp is fine, battery is good but it doesn't start. I'll have to turn the choke on everytime I need to start it.. With the choke it runs gud. But again after a half an hour rest it doesn't start up. Will have to use the choke again. What will I have to do to overcome this issue. Thanks in advance

    ReplyDelete
    Replies
    1. I don't see any harm in using the choke whenever necessary.

      Delete
  36. hi everyone, when i tried to kick start my bike in the morning, i have got a huge sound and the bike is not getting started,..wat might be the reasons

    ReplyDelete
  37. Hey my bullet 350 Electra does not start
    I checked my battery and recharged it again but no go
    After that I tried changing the fuses too
    Even the fuse tht comes inside the head light (both the fuses )
    Can u help ? I tried whatever I could !

    ReplyDelete
  38. Hey my bullet 350 Electra does not start
    I checked my battery and recharged it again but no go
    After that I tried changing the fuses too
    Even the fuse tht comes inside the head light (both the fuses )
    Can u help ? I tried whatever I could !

    ReplyDelete
  39. Hi David ! I ride a bullet 350cc Electra
    I tried starting my bike as usual but no go
    The ignition is on and the neutral light doesn't burn and none of the accessories work ( horn,indicators ,etc..)
    So I recharged my battery and fitted it back but no go again
    I even changed the fuses even the one inside the head light but still noting works and my bike doesn't start
    Wht can possibly be wrong ? Can u help?

    ReplyDelete
    Replies
    1. I would check the battery's connection to the frame for rust, paint or corrosion blocking a good connection. If that doesn't work I would suspect that the battery is not holding a sufficient charge and would try a known good battery from a different vehicle.

      Delete
  40. hi..im vijayavel..i own a 1995 standard 350 RE.im nt sure what is wrong with it but it wont start.there is gas,compression is gud ,the spark plug also seems gud..still it wont start...what could be the reason for it not starting

    ReplyDelete
    Replies
    1. Got gas? Got compression? Now you need electricity. Check the battery, fuse and wiring. Still seem good? Find a good mechanic with the equipment to find the problem.

      Delete
  41. Hey...I have a DS...seems to be battery issue as gone through the article...will be obliged if you can tell me how to fix the battery issue..?

    Vishal

    ReplyDelete
    Replies
    1. If a known good battery fixes the problem you'll have to replace your battery. If your battery is known to be good then I would find a mechanic with the tools to trace an electrical problem. Good luck.

      Delete
  42. Hi I own classic 350 2015 6 months old problem I'm facing is ignition is on but the neutral light does not glow it glows after several moves of key from left to right and right to left
    Can I know the reason?

    ReplyDelete
    Replies
    1. Could be a couple things but you're still under warranty, so why not have the dealer check it?

      Delete
  43. Hi David I'm the owner of 500cc desert Storm my problem is when I keep my bullet off for few days it won't start.this is second time I'm facing the problem.first time I got a plug problem n I change it.my bullet is just 600km run plz tell me what to do thank q

    ReplyDelete
  44. It's impossible to say from this distance but you are still under warranty, so I would suggest seeing the dealer. Have you tried asking a friend to start it? Sometimes a fresh set of eyes spots a problem. Good luck.

    ReplyDelete
  45. Hi David, I recently purchased a 2006 Bullet Electra X. This is my first bullet and I am really excited. It got shipped from Belfast (seller) to Cambridge (where I live).

    I tried to start it right away using the electric start with and without choke. I turned the accelerator in the process but the bike wouldn't start.

    I intend not to use Electric start anymore coz it may drain the battery. I am going to try the kick start over the weekend. But in general, do you think shipping bikes results in starting problems like this? Also, after how many electric start tries does the battery start to drain? And, should I use or not use the accelerator during the kick start?

    Many thanks!
    Pradeep

    ReplyDelete
    Replies
    1. As long as the headlight is nice and bright the battery should be adequate to start the motor. I would ask the Belfast seller for advice on how this bike likes to start.

      Delete
    2. Use the electric start. It's recommended. (Refer to your bike's manual).

      The right way to use the electric start is to not touch the accelerator at all. You dont need to uae the throttle, right after yoy press the ignition switch..99% people will do this mistake

      Delete
  46. Hi David, I was having a big starting problem with my 2012 Classic 350, First, I replaced its battery with a brand new one as the battery was completely dead, which didn't help much. Then I came across your article which came in real handy and I changed both of its spark plugs, which did the trick and the engine started running smoothly with just one kick. It ran fine for about 10 days and now I've started getting a different kind of problem. It starts with just 1-2 kicks but only with the choke on and as soon as I try to accelerate the engine, it just dies and won't start again easily even with the choke on now. The engine is also chocking with a blasting sound. Battery and ampmeter are working fine. Any good advice on what could be the problem here...is it the spark plugs again or the compression? or something else? I would really appreciate your tips on that and yes another thing is "I don't get to ride much frequently." thank you...Kuku

    ReplyDelete
  47. I'm sorry, I can't point to anything specific. It doesn't help that I am in the United States and we do not get the twin spark. I've never seen one.

    ReplyDelete
  48. I got problem that while I'm starting my RE Classic 350, there a big sound(like a bomb) came from silencer, then after that engine is stopped, and I tried to start the engine but it is not started please let me know the reason.

    ReplyDelete
  49. You, sir are a hero. Thanks for the information. I knew most of the stuff but was doing one thing wrong.

    I drive my bike only when I have to travel long distances. Hence my bike can stay idle for anything between 30-60 days. Starting after such a gap is always a tough nut. I follow the same routine compression, gas and battery. But what I've realised is, de compression (kicking the bike for 1-2 minutes) works best if the keys are not in and ignition is off. It takes much less effort this way. Just kick the bike a few times with ignition off and then put the keys in. Not the other way round. Also interesting to note is a lot of people when starting their bikes will not be able to shift gears,and hence the ignition light or neutral light (in new models) won't come on.they assume either the battery is dead or something is wrong with the gear system (shift). While in most cases it's only a matter of decompression.

    ReplyDelete
  50. Hi...i am facing a problem with RE Electra 201...while taking the right turn my engine stops and it will start once i move my handle to left...i checked the wires and replace the battery but still the problem remains same...

    please advise your comment

    ReplyDelete
    Replies
    1. Never had this trouble. I suggest asking advice from the Royal Enfield Yahoo Group. Experts dwell there.

      Delete
    2. Not sure if this may help, but in my Bullet sixty five, the bundle of cables coming down from the headlamp are routed to the right of the directin pipe and have moved so when turning the direction to the right, they are crushed between the direction pipe and the fork.
      If this movement has sectioned or comunicated wires under pressure, it may explain why stops at right turns only.

      Just check the wires are not crushed when turning fully right.

      Rgds

      Delete
  51. I have a 2008 Military Bullet bike and have been troubleshooting electrical for a year now. I turned the key one day & no lights, no amps; nada! I started with the battery & replaced that but still, nothing. My builder came by as I was tackling the situation and he put my multimeter on the battery to confirm continuity. Then looking at the electrical schematic (very handy) we just followed the lines back checking continuity until we got to the ignition switch; nothing! I pulled it out and pulled it apart and he even took a paper clip and jumpered it, voila! Lights came on, it even started! I couldn't believe it! I'm hoping this helps some of you with some electrical issues. It's definitely worth having small, inexpensive electrical kit on hand (I use Greenlee) to tackle these issues, especially if you're electrically challenged as myself. Now my question is, where do I get a new ignition switch for a 2008? I would like to stick with RE parts...
    ~LisaMak43

    ReplyDelete
  52. Hello David, I just want to take a moment to thank you for this lovely piece of article that came in to my help when I got stranded in a lonely road at night with no help around.
    I loved the way of writing with the slight touch of humour as all.
    Cheers,
    Karthik Rao

    ReplyDelete
  53. Hi David
    I have Electra 2010 model, my habit is turn off the fuel nob when bullet rests......and turn it on when i kick it next time....it stars easily sometimes but sometimes it takes tooo much efforts....i have to kick it for 15-16 kicks then it starts....nd sometime during riding...whenever i stops on traffic light nd turn d engine off by ignition key...it again face dat same problem...it takes tooo much kicks..
    It have new battery, new plug
    Plz suggest helpful

    ReplyDelete
    Replies
    1. Could be a lot of things, starting with a dirty spark plug. But to diagnose specific problems you're better off posting your questions on these Royal Enfield forums. Good luck.

      Delete
  54. Classic 350 2015 model neutral light dimming and when started the ammeter glass heating still working .head light on engine tends to off .. please suggest helpful

    ReplyDelete
    Replies
    1. I can't suggest anything. Try posting your question on one of the forums.

      Delete
  55. I have an old model Electra(2007) model. When I try to kick start the amp meter needle won't move, but the lights ,horn and indicator are working fine, as I put an new battery just 2 months back. What should I do! If you can help me with this please. It is not getting started since last two days. Spark plug is also new.

    ReplyDelete
    Replies
    1. When this happened to me the problem was just a loose connection inside the nacelle. Worth taking off the headlight and making sure those wires stuffed behind it are all tight. When you find the one that moves the amp meter, you've found the guilty party.

      Delete
  56. My bullet (2015 500cc)was running fine untill i added extra Mobil. Now it wont start.after trying a lot it did start but halfway it stopped on its own.now try as I may it just wont start.

    ReplyDelete
  57. Hi David
    My classic 500 efi won't start and the starter relay capacitor is making a Weird sound.
    Also the fuel pump sound (that you get when you turn to kill switch on) with the pump light going on and then off doesn't seem to functioning too.
    Are these related ??
    Thanks

    ReplyDelete
    Replies
    1. I'm sorry. I can't answer your question. I suggest posting on one of the Royal Enfield forums. Good luck.

      Delete
  58. Hi David, thanks for giving suggestions on this blog nd helping all my Enfield users
    I have Enfield classic 350cc just drived 7500 kms till date.
    I hv not used by bike for almost 10 months, I hv a very serious problem in starting by bike.
    I hv changed the engine oil. Recharged my battery. Did a normal bike service. Changed the air filter. Oil filter after doing all this also. Still the bike is not starting. Checked all the electrical things.. service guys saying issue is the valve nd compressor has bend.. due to which the vehicle is nt starting... kindly suggest

    ReplyDelete
    Replies
    1. You don't say what year your Enfield might be. If it is the old iron barrel, like mine, I would simply step on the kick starter. Does it stop nice and firmly as compression rises in the cylinder? If not, the compression could be escaping past a bad valve or compression release, as your mechanic implies. Without compression an Enfield will not start.

      Delete
  59. My Royal Enfield Electra 350cc bike battery is dead has no water in any cells and takes more time to charge. The battery is one year old only. Should i replace the battery or continue ride with that.

    ReplyDelete
    Replies
    1. I would replace the battery as soon as possible rather than put up with the problems a dead or weak battery causes.

      Delete
  60. Heyy. Hii . Yesterday i was surprised to learn that my bullet didn't start after a wash. What could be the exact problem ?

    ReplyDelete
    Replies
    1. It's my observation that washing a motorcycle sometimes causes problems that riding in the rain never does. I tolerate a little oily residue elsewhere and concentrate on cleaning only the fenders, wheels and tank. I hope you are dried off and running again now.

      Delete
  61. Heyy I'm also interesed with this article.I too have a classic 350. There is difficult in kick start and also the self start is not working.I had replaced the battery a year before with this same issue , then it was OK.But now the self is completely dead and I approached a mechanic.He told me that the sprag clutch is gone and have to replace it.
    The sprag clutch sounds new to me and with a bit of hesitation I left from there.
    So my doubt here is will the sprag clutch issue affect both the kick and self start ??
    How much does it cost??
    Do I have to check anything else before moving to the sprag clutch??
    Hope you reply

    ReplyDelete
    Replies
    1. You don't say what year your bike is, but the sprag clutch is a weak point of earlier models. It may affect only the electric start but I would have it fixed or removed (so as to leave the bike only kick start) rather than leave it in place broken. Just my personal preference.

      Delete
  62. 1//Finally, compression can escape past the piston rings. Remove the spark plug, put a dollop of oil in through the hole, replace the plug and see if compression returns. It should. //

    Hi. As we checked the above, we are not getting enough compression. service center is 45km far. don't know whether I could run my thunderbird till service center

    ReplyDelete
    Replies
    1. You don't say what year Thunderbird you have. If it is an old iron barrel model and the motorcycle starts and runs I would say you have adequate compression and it may improve with a little use. I would risk the ride.

      Delete
  63. Sir short circuit happen in my bike near battery after this bike not starting but lights,ingnition,decompresser are ok whats happening to my bike please help me sir

    ReplyDelete
    Replies
    1. If you're correct that a short circuit is to blame there is no substitute for finding and fixing it. Good luck.

      Delete
  64. Sir, my bullet 350cc one year back,engine work done, it's run 1500 kms after.... Completing engine work...sir now my problem is running time... Call came to me, I stoped my bike and I received call... On that time I off my bike... After completing my call my bike is not on by self start or by kick...sir kick also very hard it's not moving from its position... It's very very hard...besides one mechanical check petrol,battery and spark plug he told OK...he trying to start by kick, kick is moving from its position.... He told engine may be jam-packed... Sir recently one months back service Don...sir give suggestions on this problem

    ReplyDelete
    Replies
    1. If the motor has experienced a seized piston it should be checked thoroughly by a qualified mechanic. Damage may have been caused even if the piston is now free to move.

      Delete
  65. thanks alot dude. my 2003 model electra was drenched in rain and wasnt starting. the horn and signal lights werent working. connected the ignition wiring directly to battery and rode to the next workshop. thanks alot

    ReplyDelete
  66. Dear David,
    Just reading your post gave me faith and confidence that I must re-attempt to start my Thunderbird on my own, before rushing to a mechanic.
    You must've done a whole lot of good to a whole lot of people with this kind of lucid, precise and insightful writing.
    Good man!

    ReplyDelete
    Replies
    1. Kartick, that is a very kind comment. Thank you.

      Delete
  67. hi davd my royal enefeild classic 350 is just 2 days old nd I'm driven it 25 km in reserve beacause i forget to turn on the oil then suddenly today morning ny classics self isn't working nd soubd coning from a cylinder type black thing between battery chember nd tool box chember....nd now it's evening battery is totally dead lights aren't working nd kick start also not working nd my bike is bs4 ...how to fix it pllss answer me I'm in big trouble..

    ReplyDelete
    Replies
    1. Since your bike is so new you should take it to the dealer. I can't imagine any connection between using the fuel reserve and a dead battery. Good luck.

      Delete
  68. I realise doing the same thing when my 1980 machismo show these troubles, usually after heavy rains or a water wash, just sit and watch beside it after a long session of kicking and then some miracle happens, and I'm on my way

    ReplyDelete

Please patronize our advertisers

Translate this blog